third-party PEAR Archive_Tar library updates
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal core | 7.x to before 7.62; 8.6.x to before 8.6.6.; 8.5.x to before 8.5.9 | 7.62, 8.6.6., 8.5.9 | Patch available | CNA |
| — | drupal/drupal (Packagist) | 7.0.0 to before 7.62.0 | 7.62.0 | Patch available | GHSA-6rmq-x2hv-vxpp |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.5.9 | 8.5.9 | Patch available | GHSA-6rmq-x2hv-vxpp |
| — | drupal/drupal (Packagist) | 8.6.0 to before 8.6.6 | 8.6.6 | Patch available | GHSA-6rmq-x2hv-vxpp |
- Drupal core VendorDrupal Affected 7.x to before 7.62; 8.6.x to before 8.6.6.; 8.5.x to before 8.5.9 Fixed in 7.62, 8.6.6., 8.5.9 Patch available CNA
- drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.62.0 Fixed in 7.62.0 Patch available GHSA-6rmq-x2hv-vxpp
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.5.9 Fixed in 8.5.9 Patch available GHSA-6rmq-x2hv-vxpp
- drupal/drupal (Packagist) Vendor— Affected 8.6.0 to before 8.6.6 Fixed in 8.6.6 Patch available GHSA-6rmq-x2hv-vxpp
Remediation
- Fix · CNA Drupal core (Drupal) Fixed in 7.62, 8.6.6., 8.5.9
- Fix · GHSA-6rmq-x2hv-vxpp drupal/drupal (Packagist) Fixed in 7.62.0 Advisory →
- Fix · GHSA-6rmq-x2hv-vxpp drupal/drupal (Packagist) Fixed in 8.5.9 Advisory →
- Fix · GHSA-6rmq-x2hv-vxpp drupal/drupal (Packagist) Fixed in 8.6.6 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Drupal core — DSA-4370
2 records Highest priority Priority HIGH 1 HIGH, 1 LOW
Other records, highest priority first
- TI-2019-04504 PHAR stream wrapper Arbitrary PHP code executionPriority HIGH 68
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6338
- 2026-10-03 Alias added: GHSA-6rmq-x2hv-vxpp
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2019-6338 · CVE Program
- CVE-2019-6338 · NVD
- FIRST EPSS
- GHSA-6rmq-x2hv-vxpp · GitHub Advisory Database · CC BY 4.0
- CVE-2019-6338 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences