Read the docs
TI-2019-04504 Aliases CVE-2019-6339GHSA-8cw5-rv98-5c46

PHAR stream wrapper Arbitrary PHP code execution

Priority HIGH 68CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

Why it matters now

EPSS 0.3595 98th percentileScored 2026-11-07
Fix Fixed Drupal core (Drupal): 7.62, 8.6.6., 8.5.9drupal/drupal (Packagist): 7.62.0, 8.5.9, 8.6.6+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal core7.x to before 7.62; 8.6.x to before 8.6.6.; 8.5.x to before 8.5.97.62, 8.6.6., 8.5.9Patch availableCNA
—drupal/drupal (Packagist)7.0.0 to before 7.62.07.62.0Patch availableGHSA-8cw5-rv98-5c46
—drupal/drupal (Packagist)8.0.0 to before 8.5.98.5.9Patch availableGHSA-8cw5-rv98-5c46
—drupal/drupal (Packagist)8.6.0 to before 8.6.68.6.6Patch availableGHSA-8cw5-rv98-5c46
—drupal/core (Packagist)7.0.0 to before 7.62.07.62.0Patch availableGHSA-8cw5-rv98-5c46
—drupal/core (Packagist)8.0.0 to before 8.5.98.5.9Patch availableGHSA-8cw5-rv98-5c46
—drupal/core (Packagist)8.6.0 to before 8.6.68.6.6Patch availableGHSA-8cw5-rv98-5c46
  • Drupal core VendorDrupal Affected 7.x to before 7.62; 8.6.x to before 8.6.6.; 8.5.x to before 8.5.9 Fixed in 7.62, 8.6.6., 8.5.9 Patch available CNA
  • drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.62.0 Fixed in 7.62.0 Patch available GHSA-8cw5-rv98-5c46
  • drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.5.9 Fixed in 8.5.9 Patch available GHSA-8cw5-rv98-5c46
  • drupal/drupal (Packagist) Vendor— Affected 8.6.0 to before 8.6.6 Fixed in 8.6.6 Patch available GHSA-8cw5-rv98-5c46
  • drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.62.0 Fixed in 7.62.0 Patch available GHSA-8cw5-rv98-5c46
  • drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.5.9 Fixed in 8.5.9 Patch available GHSA-8cw5-rv98-5c46
  • drupal/core (Packagist) Vendor— Affected 8.6.0 to before 8.6.6 Fixed in 8.6.6 Patch available GHSA-8cw5-rv98-5c46

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*7.0 to before 7.62; 8.5.0 to before 8.5.9; 8.6.0 to before 8.6.6VulnerableDrupal
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.62; 8.5.0 to before 8.5.9; 8.6.0 to before 8.6.6 Vulnerable ·Drupal
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · CNA Drupal core (Drupal) Fixed in 7.62, 8.6.6., 8.5.9
  • Fix · GHSA-8cw5-rv98-5c46 drupal/drupal (Packagist) Fixed in 7.62.0 Advisory →
  • Fix · GHSA-8cw5-rv98-5c46 drupal/drupal (Packagist) Fixed in 8.5.9 Advisory →
  • Fix · GHSA-8cw5-rv98-5c46 drupal/drupal (Packagist) Fixed in 8.6.6 Advisory →
  • Fix · GHSA-8cw5-rv98-5c46 drupal/core (Packagist) Fixed in 7.62.0 Advisory →
  • Fix · GHSA-8cw5-rv98-5c46 drupal/core (Packagist) Fixed in 8.5.9 Advisory →
  • Fix · GHSA-8cw5-rv98-5c46 drupal/core (Packagist) Fixed in 8.6.6 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Drupal core — DSA-4370

    2 records Highest priority Priority HIGH 1 HIGH, 1 LOW

    Other records, highest priority first

    • TI-2019-04503 third-party PEAR Archive_Tar library updatesPriority LOW 39

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-6339
  2. 2026-10-03 Alias added: GHSA-8cw5-rv98-5c46

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources