Stored cross-site scripting (XSS) in WordPress block editor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | < 5.3.1 to before 5.3.1 | 5.3.1 | Patch available | CNA |
- WordPress VendorWordPress Affected < 5.3.1 to before 5.3.1 Fixed in 5.3.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | after 3.7, before 5.3.1 | Vulnerable | WordPress |
| cpe:2.3:a:wordpress:wordpress:3.7:-:*:*:*:*:*:* | 3.7 | Vulnerable | WordPress |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions after 3.7, before 5.3.1 Vulnerable ·WordPress
- cpe:2.3:a:wordpress:wordpress:3.7:-:*:*:*:*:*:* Versions 3.7 Vulnerable ·WordPress
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA WordPress (WordPress) Fixed in 5.3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WordPress 5.3.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-12561 Stored cross-site scripting (XSS) in WordPress block editorPriority LOW 29
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16780
References
Patch 1
Advisory 7
- https://wpvulndb.com/vulnerabilities/9976
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-x3wp-h3qx-9w94
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://hackerone.com/reports/738644
- 20200108 [SECURITY] [DSA 4599-1] wordpress security update
- DSA-4599
- DSA-4677
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
Sources
- CVE-2019-16780 · CVE Program
- CVE-2019-16780 · NVD
- FIRST EPSS
- CVE-2019-16780 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences