Authenticated XSS via media attachment page in WordPress
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-80.
Summary
In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | wordpress-develop | 5.4.0 to before 5.4.2; 5.3.0 to before 5.3.4; 5.2.0 to before 5.2.7; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.10; 4.9.0 to before 4.9.15; 4.8.0 to before 4.8.14; 4.7.0 to before 4.7.18; 4.6.0 to before 4.6.19; 4.5.0 to before 4.5.22; 4.4.0 to before 4.4.23; 4.3.0 to before 4.3.24; 4.2.0 to before 4.2.28; 4.1.0 to before 4.1.31; 4.0.0 to before 4.0.31; 3.9.0 to before 3.9.32; 3.8.0 to before 3.8.34; 3.7.0 to before 3.7.34 | 5.4.2, 5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34 | Patch available | CNA |
- wordpress-develop VendorWordPress Affected 5.4.0 to before 5.4.2; 5.3.0 to before 5.3.4; 5.2.0 to before 5.2.7; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.10; 4.9.0 to before 4.9.15; 4.8.0 to before 4.8.14; 4.7.0 to before 4.7.18; 4.6.0 to before 4.6.19; 4.5.0 to before 4.5.22; 4.4.0 to before 4.4.23; 4.3.0 to before 4.3.24; 4.2.0 to before 4.2.28; 4.1.0 to before 4.1.31; 4.0.0 to before 4.0.31; 3.9.0 to before 3.9.32; 3.8.0 to before 3.8.34; 3.7.0 to before 3.7.34 Fixed in 5.4.2, 5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | 3.7 to before 3.7.34; 3.8 to before 3.8.34; 3.9 to before 3.9.32; 4.0 to before 4.0.31; 4.1 to before 4.1.31; 4.2 to before 4.2.28; 4.3 to before 4.3.24; 4.4 to before 4.4.23; 4.5 to before 4.5.22; 4.6 to before 4.6.19; 4.7 to before 4.7.18; 4.8 to before 4.8.14; 4.9 to before 4.9.15; 5.0 to before 5.0.10; 5.1 to before 5.1.6; 5.2 to before 5.2.7; 5.3.0 to before 5.3.4; 5.4 to before 5.4.2 | Vulnerable | WordPress |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions 3.7 to before 3.7.34; 3.8 to before 3.8.34; 3.9 to before 3.9.32; 4.0 to before 4.0.31; 4.1 to before 4.1.31; 4.2 to before 4.2.28; 4.3 to before 4.3.24; 4.4 to before 4.4.23; 4.5 to before 4.5.22; 4.6 to before 4.6.19; 4.7 to before 4.7.18; 4.8 to before 4.8.14; 4.9 to before 4.9.15; 5.0 to before 5.0.10; 5.1 to before 5.1.6; 5.2 to before 5.2.7; 5.3.0 to before 5.3.4; 5.4 to before 5.4.2 Vulnerable ·WordPress
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA wordpress-develop (WordPress) Fixed in 5.4.2, 5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
wordpress-develop — FEDORA-2020-bbedd29391
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2020-03537 Open redirect in wp_validate_redirect() in WordPressPriority LOW 30
- TI-2020-03535 Authenticated XSS through embed block in WordPressPriority LOW 29
- TI-2020-03539 set-screen-option filter misuse by plugins leading to privilege escalation in WordPressPriority LOW 20
- Advisory ·
wordpress-develop — FEDORA-2020-8447a3e195
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2020-03537 Open redirect in wp_validate_redirect() in WordPressPriority LOW 30
- TI-2020-03535 Authenticated XSS through embed block in WordPressPriority LOW 29
- TI-2020-03539 set-screen-option filter misuse by plugins leading to privilege escalation in WordPressPriority LOW 20
Show 1 more group
- Advisory ·
wordpress-develop — DSA-4709
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2020-03537 Open redirect in wp_validate_redirect() in WordPressPriority LOW 30
- TI-2020-03535 Authenticated XSS through embed block in WordPressPriority LOW 29
- TI-2020-03539 set-screen-option filter misuse by plugins leading to privilege escalation in WordPressPriority LOW 20
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-4047
References
Patch 1
Advisory 7
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27
- FEDORA-2020-8447a3e195
- FEDORA-2020-bbedd29391
- DSA-4709
- [debian-lts-announce] 20200701 [SECURITY] [DLA 2269-1] wordpress security update
- [debian-lts-announce] 20200911 [SECURITY] [DLA 2371-1] wordpress security update
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
Sources
- CVE-2020-4047 · CVE Program
- CVE-2020-4047 · NVD
- FIRST EPSS
- CVE-2020-4047 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences