Specially crafted filenames in WordPress leading to XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | 5.4.0 to before 5.4.1; 5.3.0 to before 5.3.3; 5.2.0 to before 5.2.6; 5.1.0 to before 5.1.5; 5.0.0 to before 5.0.9; 4.9.0 to before 4.9.14; 4.8.0 to before 4.8.13; 4.7.0 to before 4.7.17; 4.6.0 to before 4.6.18; 4.5.0 to before 4.5.21; 4.4.0 to before 4.4.22; 4.3.0 to before 4.3.23; 4.2.0 to before 4.2.27; 4.1.0 to before 4.1.30; 4.0.0 to before 4.0.30; 3.9.0 to before 3.9.31; 3.8.0 to before 3.8.33; 3.7.0 to before 3.7.33 | 5.4.1, 5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33 | Patch available | CNA |
- WordPress VendorWordPress Affected 5.4.0 to before 5.4.1; 5.3.0 to before 5.3.3; 5.2.0 to before 5.2.6; 5.1.0 to before 5.1.5; 5.0.0 to before 5.0.9; 4.9.0 to before 4.9.14; 4.8.0 to before 4.8.13; 4.7.0 to before 4.7.17; 4.6.0 to before 4.6.18; 4.5.0 to before 4.5.21; 4.4.0 to before 4.4.22; 4.3.0 to before 4.3.23; 4.2.0 to before 4.2.27; 4.1.0 to before 4.1.30; 4.0.0 to before 4.0.30; 3.9.0 to before 3.9.31; 3.8.0 to before 3.8.33; 3.7.0 to before 3.7.33 Fixed in 5.4.1, 5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | 3.7 to before 3.7.33; 3.8 to before 3.8.33; 3.9 to before 3.9.31; 4.0 to before 4.0.30; 4.1 to before 4.1.30; 4.2 to before 4.2.27; 4.3 to before 4.3.23; 4.4 to before 4.4.22; 4.5 to before 4.5.21; 4.6 to before 4.6.18; 4.7 to before 4.7.17; 4.8 to before 4.8.13; 4.9 to before 4.9.14; 5.0 to before 5.0.9; 5.1 to before 5.1.5; 5.2 to before 5.2.6; 5.3 to before 5.3.3 | Vulnerable | WordPress |
| cpe:2.3:a:wordpress:wordpress:5.4:*:*:*:*:*:*:* | 5.4 | Vulnerable | WordPress |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions 3.7 to before 3.7.33; 3.8 to before 3.8.33; 3.9 to before 3.9.31; 4.0 to before 4.0.30; 4.1 to before 4.1.30; 4.2 to before 4.2.27; 4.3 to before 4.3.23; 4.4 to before 4.4.22; 4.5 to before 4.5.21; 4.6 to before 4.6.18; 4.7 to before 4.7.17; 4.8 to before 4.8.13; 4.9 to before 4.9.14; 5.0 to before 5.0.9; 5.1 to before 5.1.5; 5.2 to before 5.2.6; 5.3 to before 5.3.3 Vulnerable ·WordPress
- cpe:2.3:a:wordpress:wordpress:5.4:*:*:*:*:*:*:* Versions 5.4 Vulnerable ·WordPress
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA WordPress (WordPress) Fixed in 5.4.1, 5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-11026
References
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
Sources
- CVE-2020-11026 · CVE Program
- CVE-2020-11026 · NVD
- FIRST EPSS
- CVE-2020-11026 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences