Integer overflow in polonel/trudesk
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
The trudesk application allows large characters to insert in the input field "Full Name" on the signup field which can allow attackers to cause a Denial of Service (DoS) via a crafted HTTP request in GitHub repository polonel/trudesk prior to 1.2.2. This can lead to Denial of service.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA polonel/trudesk (polonel) Fixed in 1.2.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
polonel/trudesk 1.2.2
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-01594 Allowing long password leads to denial of service in polonel/trudesk in polonel/trudeskPriority LOW 31
- TI-2022-01585 Reflected XSS on ticket filter function in polonel/trudeskPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1718
- 2026-10-03 Alias added: GHSA-733x-qm55-w9g4
References
More polonel Trudesk vulnerabilities
- TI-2026-78782 Username enumeration via regex injection in Trudesk login CVSS 4.0MEDIUM 6.9
- TI-2026-78773 Authorization bypass in Trudesk ticket API lets users read other tickets CVSS 4.0MEDIUM 6.9
- TI-2026-78781 Trudesk Missing Authentication for Ticket Attachments via /uploads CVSS 4.0HIGH 8.2
- TI-2026-78778 Missing authentication on Trudesk debug routes enables data deletion CVSS 4.0HIGH 8.3
- TI-2026-78777 MongoDB $where injection in Trudesk ticket search API CVSS 4.0HIGH 7.1
- TI-2021-20836 TruDesk Help Desk/Ticketing Solution v1.1.11 is vulnerable to a Cross-Site Request… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-1718 · CVE Program
- CVE-2022-1718 · NVD
- FIRST EPSS
- GHSA-733x-qm55-w9g4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences