Reflected XSS on ticket filter function in polonel/trudesk
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Reflected XSS on ticket filter function in GitHub repository polonel/trudesk prior to 1.2.2. This vulnerability is capable of executing a malicious javascript code in web page
Why it matters now
EPSS 0.00735 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed polonel/trudesk (polonel): 1.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA polonel/trudesk (polonel) Fixed in 1.2.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
polonel/trudesk 1.2.2
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-01584 Integer overflow in polonel/trudeskPriority LOW 35
- TI-2022-01594 Allowing long password leads to denial of service in polonel/trudesk in polonel/trudeskPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1719
- 2026-10-03 Alias added: GHSA-9g28-m7m5-fqf2
References
More polonel Trudesk vulnerabilities
- TI-2026-78782 Username enumeration via regex injection in Trudesk login CVSS 4.0MEDIUM 6.9
- TI-2026-78773 Authorization bypass in Trudesk ticket API lets users read other tickets CVSS 4.0MEDIUM 6.9
- TI-2026-78781 Trudesk Missing Authentication for Ticket Attachments via /uploads CVSS 4.0HIGH 8.2
- TI-2026-78778 Missing authentication on Trudesk debug routes enables data deletion CVSS 4.0HIGH 8.3
- TI-2026-78777 MongoDB $where injection in Trudesk ticket search API CVSS 4.0HIGH 7.1
- TI-2021-20836 TruDesk Help Desk/Ticketing Solution v1.1.11 is vulnerable to a Cross-Site Request… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-1719 · CVE Program
- CVE-2022-1719 · NVD
- FIRST EPSS
- GHSA-9g28-m7m5-fqf2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences