Drupal core - Moderately critical - Defacement - SA-CORE-2025-007
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-451.
Summary
User Interface (UI) Misrepresentation of Critical Information vulnerability in Drupal Drupal core allows Content Spoofing.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal core | 8.0.0 to before 10.4.9; 10.5.0 to before 10.5.6; 11.0.0 to before 11.1.9; 11.2.0 to before 11.2.8 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.0.0 to before 10.4.9 | 10.4.9 | Patch available | GHSA-h89p-5896-f4q8 |
| — | drupal/core (Packagist) | 10.5.0 to before 10.5.6 | 10.5.6 | Patch available | GHSA-h89p-5896-f4q8 |
| — | drupal/core (Packagist) | 11.0.0 to before 11.1.9 | 11.1.9 | Patch available | GHSA-h89p-5896-f4q8 |
| — | drupal/core (Packagist) | 11.2.0 to before 11.2.8 | 11.2.8 | Patch available | GHSA-h89p-5896-f4q8 |
- Drupal core VendorDrupal Affected 8.0.0 to before 10.4.9; 10.5.0 to before 10.5.6; 11.0.0 to before 11.1.9; 11.2.0 to before 11.2.8 Fixed in 10.4.9, 10.5.6, 11.1.9, 11.2.8 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 10.4.9 Fixed in 10.4.9 Patch available GHSA-h89p-5896-f4q8
- drupal/core (Packagist) Vendor— Affected 10.5.0 to before 10.5.6 Fixed in 10.5.6 Patch available GHSA-h89p-5896-f4q8
- drupal/core (Packagist) Vendor— Affected 11.0.0 to before 11.1.9 Fixed in 11.1.9 Patch available GHSA-h89p-5896-f4q8
- drupal/core (Packagist) Vendor— Affected 11.2.0 to before 11.2.8 Fixed in 11.2.8 Patch available GHSA-h89p-5896-f4q8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.0.0 to before 10.4.9; 10.5.0 to before 10.5.6; 11.0.0 to before 11.1.9; 11.2.0 to before 11.2.8 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 10.4.9; 10.5.0 to before 10.5.6; 11.0.0 to before 11.1.9; 11.2.0 to before 11.2.8 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal core (Drupal) Fixed in 10.4.9, 10.5.6, 11.1.9, 11.2.8
- Fix · GHSA-h89p-5896-f4q8 drupal/core (Packagist) Fixed in 10.4.9 Advisory →
- Fix · GHSA-h89p-5896-f4q8 drupal/core (Packagist) Fixed in 10.5.6 Advisory →
- Fix · GHSA-h89p-5896-f4q8 drupal/core (Packagist) Fixed in 11.1.9 Advisory →
- Fix · GHSA-h89p-5896-f4q8 drupal/core (Packagist) Fixed in 11.2.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal core 10.4.9, 10.5.6 and 2 more versions
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2025-11964 Drupal core - Moderately critical - Denial of Service - SA-CORE-2025-005Priority LOW 30
- TI-2025-11965 Drupal core - Moderately critical - Gadget chain - SA-CORE-2025-006Priority LOW 28
- TI-2025-11967 Drupal core - Moderately critical - Information disclosure - SA-CORE-2025-008Priority LOW 17
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13082
- 2026-10-03 Alias added: GHSA-h89p-5896-f4q8
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-13082 · CVE Program
- CVE-2025-13082 · NVD
- FIRST EPSS
- GHSA-h89p-5896-f4q8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-13082 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences