Read the docs
TI-2025-22817 Aliases CVE-2025-31673GHSA-wpp8-fjgf-pwc7

Drupal core - Moderately critical - Access bypass - SA-CORE-2025-002

Priority LOW 21CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Incorrect Authorization vulnerability in Drupal Drupal core allows Forceful Browsing.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00317 24th percentileScored 2026-11-07
Fix Fixed Drupal core (Drupal): 10.3.13, 10.4.3, 11.0.12 +1drupal/core (Packagist): 10.3.13, 10.4.3, 11.0.12 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal core8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.310.3.13, 10.4.3, 11.0.12, 11.1.3Patch availableCNA
—drupal/core (Packagist)8.0.0 to before 10.3.1310.3.13Patch availableGHSA-wpp8-fjgf-pwc7
—drupal/core (Packagist)10.4.0 to before 10.4.310.4.3Patch availableGHSA-wpp8-fjgf-pwc7
—drupal/core (Packagist)11.0.0 to before 11.0.1211.0.12Patch availableGHSA-wpp8-fjgf-pwc7
—drupal/core (Packagist)11.1.0 to before 11.1.311.1.3Patch availableGHSA-wpp8-fjgf-pwc7
  • Drupal core VendorDrupal Affected 8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3 Fixed in 10.3.13, 10.4.3, 11.0.12, 11.1.3 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.0.0 to before 10.3.13 Fixed in 10.3.13 Patch available GHSA-wpp8-fjgf-pwc7
  • drupal/core (Packagist) Vendor— Affected 10.4.0 to before 10.4.3 Fixed in 10.4.3 Patch available GHSA-wpp8-fjgf-pwc7
  • drupal/core (Packagist) Vendor— Affected 11.0.0 to before 11.0.12 Fixed in 11.0.12 Patch available GHSA-wpp8-fjgf-pwc7
  • drupal/core (Packagist) Vendor— Affected 11.1.0 to before 11.1.3 Fixed in 11.1.3 Patch available GHSA-wpp8-fjgf-pwc7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3 Vulnerable ·Drupal

Remediation

  • Fix · CNA Drupal core (Drupal) Fixed in 10.3.13, 10.4.3, 11.0.12, 11.1.3
  • Fix · GHSA-wpp8-fjgf-pwc7 drupal/core (Packagist) Fixed in 10.3.13 Advisory →
  • Fix · GHSA-wpp8-fjgf-pwc7 drupal/core (Packagist) Fixed in 10.4.3 Advisory →
  • Fix · GHSA-wpp8-fjgf-pwc7 drupal/core (Packagist) Fixed in 11.0.12 Advisory →
  • Fix · GHSA-wpp8-fjgf-pwc7 drupal/core (Packagist) Fixed in 11.1.3 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Drupal core 10.3.13, 10.4.3 and 2 more versions

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2025-22818 Drupal core - Moderately critical - Gadget Chain - SA-CORE-2025-003Priority LOW 36
    • TI-2025-02669 Drupal core - Critical - Cross site scripting - SA-CORE-2025-001Priority LOW 27

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-31673
  2. 2026-10-03 Alias added: GHSA-wpp8-fjgf-pwc7

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources