Drupal core - Moderately critical - Gadget Chain - SA-CORE-2025-003
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-915.
Summary
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal core | 8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3 | 10.3.13, 10.4.3, 11.0.12, 11.1.3 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.0.0 to before 10.3.13 | 10.3.13 | Patch available | GHSA-2qph-q8xw-gv7q |
| — | drupal/core (Packagist) | 10.4.0 to before 10.4.3 | 10.4.3 | Patch available | GHSA-2qph-q8xw-gv7q |
| — | drupal/core (Packagist) | 11.0.0 to before 11.0.12 | 11.0.12 | Patch available | GHSA-2qph-q8xw-gv7q |
| — | drupal/core (Packagist) | 11.1.0 to before 11.1.3 | 11.1.3 | Patch available | GHSA-2qph-q8xw-gv7q |
- Drupal core VendorDrupal Affected 8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3 Fixed in 10.3.13, 10.4.3, 11.0.12, 11.1.3 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 10.3.13 Fixed in 10.3.13 Patch available GHSA-2qph-q8xw-gv7q
- drupal/core (Packagist) Vendor— Affected 10.4.0 to before 10.4.3 Fixed in 10.4.3 Patch available GHSA-2qph-q8xw-gv7q
- drupal/core (Packagist) Vendor— Affected 11.0.0 to before 11.0.12 Fixed in 11.0.12 Patch available GHSA-2qph-q8xw-gv7q
- drupal/core (Packagist) Vendor— Affected 11.1.0 to before 11.1.3 Fixed in 11.1.3 Patch available GHSA-2qph-q8xw-gv7q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 10.3.13; 10.4.0 to before 10.4.3; 11.0.0 to before 11.0.12; 11.1.0 to before 11.1.3 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal core (Drupal) Fixed in 10.3.13, 10.4.3, 11.0.12, 11.1.3
- Fix · GHSA-2qph-q8xw-gv7q drupal/core (Packagist) Fixed in 10.3.13 Advisory →
- Fix · GHSA-2qph-q8xw-gv7q drupal/core (Packagist) Fixed in 10.4.3 Advisory →
- Fix · GHSA-2qph-q8xw-gv7q drupal/core (Packagist) Fixed in 11.0.12 Advisory →
- Fix · GHSA-2qph-q8xw-gv7q drupal/core (Packagist) Fixed in 11.1.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal core 10.3.13, 10.4.3 and 2 more versions
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2025-02669 Drupal core - Critical - Cross site scripting - SA-CORE-2025-001Priority LOW 27
- TI-2025-22817 Drupal core - Moderately critical - Access bypass - SA-CORE-2025-002Priority LOW 21
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31674
- 2026-10-03 Alias added: GHSA-2qph-q8xw-gv7q
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-31674 · CVE Program
- CVE-2025-31674 · NVD
- FIRST EPSS
- GHSA-2qph-q8xw-gv7q · GitHub Advisory Database · CC BY 4.0
- CVE-2025-31674 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences