Insufficient verification of data authenticity in simplesamlphp
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-345.
Summary
SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. Prior to 2.4.7 and 2.5.2, SimpleSAMLphp's SAML SP ACS path does not enforce the IdP selected for an SP-initiated login when unsigned Response/InResponseTo is combined with a signed assertion lacking SubjectConfirmationData/InResponseTo, allowing a response issued by one trusted IdP to be bound to SP state created for another IdP and bypass flows that route users to a specific IdP, including deployments that set enable_unsolicited to false. This issue is fixed in versions 2.4.7 and 2.5.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| simplesamlphp | simplesamlphp | before 2.4.7; 2.5.0-rc1 to before 2.5.2 | 2.4.7, 2.5.2 | Patch available | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | 2.5.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-q8r6-xj3f-wrrm |
| — | simplesamlphp/simplesamlphp (Packagist) | before 2.4.7 | 2.4.7 | Patch available | GHSA-q8r6-xj3f-wrrm |
- simplesamlphp Vendorsimplesamlphp Affected before 2.4.7; 2.5.0-rc1 to before 2.5.2 Fixed in 2.4.7, 2.5.2 Patch available CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected 2.5.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-q8r6-xj3f-wrrm
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 2.4.7 Fixed in 2.4.7 Patch available GHSA-q8r6-xj3f-wrrm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | before 2.4.7; 2.5.0 to before 2.5.2 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions before 2.4.7; 2.5.0 to before 2.5.2 Vulnerable ·simplesamlphp
Remediation
- Fix · CNA simplesamlphp (simplesamlphp) Fixed in 2.4.7, 2.5.2
- Fix · GHSA-q8r6-xj3f-wrrm simplesamlphp/simplesamlphp (Packagist) Fixed in 2.5.2 Advisory →
- Fix · GHSA-q8r6-xj3f-wrrm simplesamlphp/simplesamlphp (Packagist) Fixed in 2.4.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-49284
- 2026-10-03 Alias added: GHSA-q8r6-xj3f-wrrm
References
More Simplesamlphp vulnerabilities
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2017-09530 The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and… CVSS 3.0CRITICAL 9.8
- TI-2017-09535 SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive… CVSS 3.0CRITICAL 9.8
- TI-2016-07944 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and… CVSS 3.0CRITICAL 9.1
- TI-2019-02593 Improper signature verification in Rob Richards XmlSecLibs CVSS 3.1HIGH 8.8
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
Sources
- CVE-2026-49284 · CVE Program
- CVE-2026-49284 · NVD
- FIRST EPSS
- GHSA-q8r6-xj3f-wrrm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences