Read the docs

Access bypass in Drupal Commerce Core via forceful browsing

Priority LOW 19CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.

Summary

Drupal Commerce Core versions from 0.0.0 before 2.41.0 and from 3.0.0 before 3.3.13 are affected. An incorrect authorization check (CWE-863) allows forceful browsing. A remote attacker with low privileges can exploit this without user interaction, and the impact on integrity is limited.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

Incorrect Authorization vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00193 9th percentileScored 2026-11-07
Fix Fixed Commerce Core (Drupal): 2.41.0, 3.3.13

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCommerce Core0.0.0 to before 2.41.0; 3.0.0 to before 3.3.132.41.0, 3.3.13Patch availableCNA
  • Commerce Core VendorDrupal Affected 0.0.0 to before 2.41.0; 3.0.0 to before 3.3.13 Fixed in 2.41.0, 3.3.13 Patch available CNA

Remediation

Upgrade Drupal Commerce Core to 2.41.0 for the 2.x branch or to 3.3.13 for the 3.x branch, as described in security advisory SA-CONTRIB-2026-256.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

  • Fix · CNA Commerce Core (Drupal) Fixed in 2.41.0, 3.3.13

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Drupal Commerce Core 2.41.0, 3.3.13

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2026-82893 Cross-site request forgery in Drupal Commerce CorePriority LOW 29
    • TI-2026-82894 Sensitive data exposure in Drupal Commerce Core data queriesPriority LOW 17
    • TI-2026-82892 Drupal Commerce Core access bypass (moderately critical)Priority LOW 13

Timeline

  1. 2026-10-30 Threatist record created from CVE-2026-118541
  2. 2026-10-30 Alias added: GHSA-p6j3-r2g3-f8vm
  3. 2026-11-06 CVSS score added · CISA ADP
  4. 2026-11-06 CISA SSVC decision points changed

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources