Drupal Commerce Core access bypass (moderately critical)
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
Drupal Commerce Core from 0.0.0 before 2.41.0 and from 3.0.0 before 3.3.13 contains an incorrect authorization flaw (CWE-863) that allows forceful browsing. A remote attacker with high privileges can reach pages that should be restricted, with a low impact on integrity.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Incorrect Authorization vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Drupal Commerce Core to version 2.41.0 or 3.3.13, as described in Drupal security advisory SA-CONTRIB-2026-257.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Commerce Core (Drupal) Fixed in 2.41.0, 3.3.13
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Commerce Core 2.41.0, 3.3.13
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-82893 Cross-site request forgery in Drupal Commerce CorePriority LOW 29
- TI-2026-82891 Access bypass in Drupal Commerce Core via forceful browsingPriority LOW 19
- TI-2026-82894 Sensitive data exposure in Drupal Commerce Core data queriesPriority LOW 17
Timeline
- 2026-10-30 Threatist record created from CVE-2026-118542
- 2026-10-30 Alias added: GHSA-65mh-qgf4-7wgx
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-118542 · CVE Program
- CVE-2026-118542 · NVD
- FIRST EPSS
- GHSA-65mh-qgf4-7wgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences