Read the docs

Sensitive data exposure in Drupal Commerce Core data queries

Priority LOW 17CWE-202Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

Drupal Commerce Core versions from 0.0.0 before 2.41.0 and from 3.0.0 before 3.3.13 are affected. A flaw in data queries (CWE-202) exposes sensitive information. A remote attacker without privileges can reach that data through forceful browsing, though the attack is hard to carry out.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

Exposure of Sensitive Information Through Data Queries vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00197 9th percentileScored 2026-11-07
Fix Fixed Commerce Core (Drupal): 2.41.0, 3.3.13

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCommerce Core0.0.0 to before 2.41.0; 3.0.0 to before 3.3.132.41.0, 3.3.13Patch availableCNA
  • Commerce Core VendorDrupal Affected 0.0.0 to before 2.41.0; 3.0.0 to before 3.3.13 Fixed in 2.41.0, 3.3.13 Patch available CNA

Remediation

Fixed versions are 2.41.0 and 3.3.13 for Drupal Commerce Core, as described in advisory SA-CONTRIB-2026-259.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

  • Fix · CNA Commerce Core (Drupal) Fixed in 2.41.0, 3.3.13

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Drupal Commerce Core 2.41.0, 3.3.13

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2026-82893 Cross-site request forgery in Drupal Commerce CorePriority LOW 29
    • TI-2026-82891 Access bypass in Drupal Commerce Core via forceful browsingPriority LOW 19
    • TI-2026-82892 Drupal Commerce Core access bypass (moderately critical)Priority LOW 13

Timeline

  1. 2026-10-30 Threatist record created from CVE-2026-118544
  2. 2026-10-30 Alias added: GHSA-v5mv-g539-3hqf
  3. 2026-11-06 CVSS score added · CISA ADP
  4. 2026-11-06 CISA SSVC decision points changed

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources