Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

124 records

Priority HIGH 75

LibreNMS before 26.9.0 contains an LDAP filter injection in ldap-authorization and ad-authorization modes because usernames are inserted unescaped into LDAP search filters and authentication only checks user existence.

CVSS 4.0CRITICAL 9.2 Network No auth No interaction EPSS 0.00596 Published 2026-10-12 Fixed in 26.9.0 CWE-90
Priority LOW 23

LibreNMS before 26.9.0 contains a missing authorization vulnerability in PortsController::purge that allows global-read users to physically delete ports without delete privileges.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00192 Published 2026-10-12 Fixed in 26.9.0 CWE-862
Priority LOW 23

LibreNMS before 26.9.0 contains a stored cross-site scripting vulnerability in get_oxidized_nodes_list() that renders Oxidized API fields and SNMP sysName unescaped.

CVSS 4.0MEDIUM 5.3 Network No auth User interaction EPSS 0.00188 Published 2026-10-12 Fixed in 26.9.0 CWE-79
Priority LOW 24

LibreNMS before 26.9.0 contains a path traversal vulnerability in nfsen_channel_common.inc.php that allows authenticated users to read unauthorized RRD data by injecting ../ sequences into the channel parameter.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00275 Published 2026-10-12 Fixed in 26.9.0 CWE-22
Priority MEDIUM 64

LibreNMS before 26.9.0 contains an SQL injection vulnerability that allows unprivileged users to inject SQL by supplying an array-valued notification_id parameter to notifications.inc.php.

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00294 Published 2026-10-12 Fixed in 26.9.0 CWE-89
Priority MEDIUM 57

LibreNMS before 26.9.0 contains a stored cross-site scripting vulnerability in includes/html/pages/device/wireless.inc.php, which echoes wireless sensor sensor_descr values, populated from SNMP DisplayString fields durin…

CVSS 4.0MEDIUM 5.3 Network No auth User interaction EPSS 0.0024 Published 2026-10-12 Fixed in 26.9.0 CWE-79
Priority MEDIUM 57

LibreNMS through 26.9.1.1 contains an authorization bypass vulnerability in includes/html/graphs/smokeping/auth.inc.php that checks the src probe device instead of the rendered target device.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00269 Published 2026-10-11 No fix listed CWE-639
TI-2020-12494 CVE-2020-15875 · GHSA-63h9-9gmf-c466

SQL injection in LibreNMS

Priority MEDIUM 56

An issue was discovered in LibreNMS 1.65.

CVSS 3.1MEDIUM 5.0 Network Low privileges No interaction EPSS 0.00463 Published 2026-09-13 Fixed in 1.65.1 CWE-89
Priority MEDIUM 41

LibreNMS before 26.8.0 contains an argument injection vulnerability in the graph_title parameter that allows authenticated attackers to inject arbitrary rrdtool arguments by breaking out of double-quote escaping.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00605 Published 2026-09-07 Fixed in 26.8.0 CWE-77
Priority HIGH 75

LibreNMS before 26.8.0 contains an authentication bypass vulnerability in the REST API that allows unauthenticated attackers to access protected endpoints by sending numeric values instead of string tokens.

CVSS 4.0CRITICAL 9.2 Network No auth No interaction EPSS 0.04358 Published 2026-09-07 Fixed in 26.8.0 CWE-287
Priority HIGH 72

LibreNMS versions >= 23.10.0 and < 26.2.0 (fixed in 26.4.0) contain an authenticated OS command injection vulnerability in libvirt discovery.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01526 Published 2026-09-01 Fixed in 26.4.0 CWE-78
Priority MEDIUM 59

LibreNMS through 26.2.0 contains a stored cross-site scripting vulnerability in legacy PHP template pages that render unescaped SNMP-sourced data fields including BGP peer descriptions, VRF names, process information, an…

CVSS 4.0MEDIUM 5.8 Network High privileges User interaction EPSS 0.00349 Published 2026-09-01 No fix listed CWE-79
Priority MEDIUM 64

LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping.

CVSS 4.0HIGH 7.1 Network No auth User interaction EPSS 0.00331 Published 2026-09-01 Fixed in 26.3.1 CWE-79
Priority LOW 30

LibreNMS before 26.5.0 contains stored cross-site scripting vulnerabilities in VRF display pages where mplsVpnVrfDescription, vrf_name, and mplsVpnVrfRouteDistinguisher fields from SNMP polling are rendered without sanit…

CVSS 4.0MEDIUM 5.3 Network No auth User interaction EPSS 0.00263 Published 2026-09-01 Fixed in 26.5.0 CWE-79
Priority HIGH 73

LibreNMS versions before 26.5.0 contain a remote code execution vulnerability in the AboutController where the snmpget configuration parameter is passed to shell_exec() without proper validation.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00863 Published 2026-09-01 Fixed in 26.5.0 CWE-77
Priority HIGH 75

LibreNMS through 26.4.0 renders JSON fields (name, ip, model, author, commit message) returned by the admin-configurable Oxidized integration URL (oxidized.url) into the device showconfig page without applying htmlspecia…

CVSS 4.0CRITICAL 9.2 Network High privileges User interaction EPSS 0.00382 Published 2026-09-01 Fixed in 26.7.0 CWE-79
Priority MEDIUM 55

LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php…

CVSS 4.0MEDIUM 4.8 Network High privileges User interaction EPSS 0.00251 Published 2026-09-01 Fixed in 26.7.0 CWE-79
TI-2026-55455 CVE-2026-80214 · GHSA-gq95-24rp-w6h2

LibreNMS Virtualisation Discovery Module RCE

Priority HIGH 72

LibreNMS’s Virtualization Discovery module is vulnerable to command line injection.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.00539 Published 2026-08-26 Fixed in 26.4.1 CWE-78
Priority HIGH 72

LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().

CVSS 3.1CRITICAL 9.1 Network Low privileges No interaction EPSS 0.07176 Published 2026-05-08 Fixed in 24.10.0 CWE-78
TI-2026-05445 CVE-2026-6204 · GHSA-pr3g-phhr-h8fh

OS command injection in librenms

Priority HIGH 72

LibreNMS versions before 26.3.0 are affected by an authenticated remote code execution vulnerability by abusing the Binary Locations config and the Netcommand feature.

CVSS 4.0HIGH 8.5 Network High privileges No interaction EPSS 0.07533 Published 2026-04-13 Fixed in 26.3.0 CWE-78
TI-2026-02335 CVE-2026-2728 · GHSA-5gm9-622f-qcg5

Cross-site scripting in librenms

Priority MEDIUM 54

LibreNMS versions before 26.3.0 are affected by an authenticated Cross-site Scripting vulnerability on the showconfig page.

CVSS 4.0MEDIUM 4.6 Network High privileges User interaction EPSS 0.00225 Published 2026-04-13 Fixed in 26.3.0 CWE-79
Load more