Priority MEDIUM 40
ZenML 0.94.6 contains a remote code execution vulnerability in the CloudpickleMaterializer component that allows attackers with write access to a shared artifact store to execute arbitrary code by planting a malicious pi…
CVSS 4.0HIGH 8.5· Network · Low privileges · User interaction · EPSS 0.00755 · Published 2026-08-07 · No fix listed CWE-502
Priority HIGH 68
A vulnerability in zenml-io/zenml versions 0.57.0 through 0.94.2 allows an attacker to bypass rate-limiting on the `POST /api/v1/login` and self password-change endpoints by rotating the `X-Forwarded-For` header.
CVSS 3.0MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00219 · Published 2026-07-24 · Fixed in 0.95.0 CWE-290
Priority MEDIUM 56
In zenml-io/zenml version 0.94.2, the `GET /api/v1/stack-deployment/stack` endpoint (`get_deployed_stack`) lacks proper RBAC authorization checks, allowing any authenticated user to enumerate all deployed stacks across a…
CVSS 3.0MEDIUM 5.0· Network · Low privileges · No interaction · EPSS 0.0023 · Published 2026-07-21 · Fixed in 0.95.0 CWE-862
Priority HIGH 69
ZenML version 0.83.1 is affected by a path traversal vulnerability in the `PathMaterializer` class.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.00365 · Published 2025-10-05 · Fixed in 0.84.2 CWE-22
Priority HIGH 72
A Denial of Service (DoS) vulnerability in zenml-io/zenml version 0.66.0 allows unauthenticated attackers to cause excessive resource consumption by sending malformed multipart requests with arbitrary characters appended…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.0097 · Published 2025-03-20 · Fixed in 0.68.0 CWE-835
Priority MEDIUM 58
zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00508 · Published 2024-11-14 · Fixed in 0.57.0, 0.57.0rc2 CWE-770
Priority MEDIUM 60
A reflected Cross-Site Scripting (XSS) vulnerability was identified in zenml-io/zenml version 0.57.1.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00388 · Published 2024-06-30 · Fixed in 0.58.0 CWE-79
Priority HIGH 71
A vulnerability in zenml-io/zenml version 0.56.3 allows attackers to reuse old session credentials or session IDs due to insufficient session expiration.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00408 · Published 2024-06-08 · No fix listed CWE-613
Priority MEDIUM 48
A race condition vulnerability exists in zenml-io/zenml versions up to and including 0.55.3, which allows for the creation of multiple users with the same username when requests are sent in parallel.
CVSS 3.1LOW 3.1· Network · High privileges · User interaction · EPSS 0.00289 · Published 2024-06-06 · Fixed in 0.55.5 CWE-366
Priority MEDIUM 62
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint.
CVSS 3.1MEDIUM 6.5· Network · High privileges · No interaction · EPSS 0.00623 · Published 2024-06-06 · Fixed in 0.56.2 CWE-862
Priority MEDIUM 55
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00364 · Published 2024-06-06 · Fixed in 0.56.2 CWE-79
Priority MEDIUM 49
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4.
CVSS 3.1LOW 3.3· Local · Low privileges · No interaction · EPSS 0.00241 · Published 2024-06-06 · Fixed in 0.56.3 CWE-620
Priority MEDIUM 60
A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the application's failure to set appropriate X-Frame-Options or Content-Security-Policy HTTP headers.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00354 · Published 2024-06-06 · Fixed in 0.56.3 CWE-1021
Priority HIGH 76
A directory traversal vulnerability exists in the zenml-io/zenml repository, specifically within the /api/v1/steps endpoint.
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.37235 · Published 2024-04-16 · Fixed in 0.55.5 CWE-29
Priority MEDIUM 53
A session fixation vulnerability exists in the zenml-io/zenml application, where JWT tokens used for user authentication are not invalidated upon logout.
CVSS 3.1MEDIUM 4.2· Network · No auth · User interaction · EPSS 0.00433 · Published 2024-04-16 · Fixed in 0.56.2 CWE-384
Priority MEDIUM 41
zenml v0.55.4 was discovered to contain an arbitrary file upload vulnerability in the load function at /materializers/cloudpickle_materializer.py.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00713 · Published 2024-03-14 · No fix listed CWE-94
Priority HIGH 78
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.70785 · Published 2024-02-27 · Fixed in 0.42.2, 0.43.1 +2 CWE-284