Priority CRITICAL 90KEV
The HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.99999 · Published 2023-10-10 · Partial fix · 1.28.0, 0.17.0 +9 CWE-400
Priority HIGH 78
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module.
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.68047 · Published 2026-05-13 · Fixed in R37, R36 P4 +3 CWE-122
Priority HIGH 75
A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and a string expression references the map's regex capture variables before referencing the map output variable.
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.06296 · Published 2026-07-15 · Partial fix · 37.0.3.1, R36 P7 +2 CWE-122
Priority MEDIUM 55
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module.
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.10856 · Published 2026-05-22 · Partial fix · 37.0.1.1, R36 P5 +3 CWE-122
Priority MEDIUM 51
NGINX Open Source has a vulnerability in the ngx_http_v3_module module.
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.06218 · Published 2026-06-17 · Fixed in 1.31.2 CWE-416
Priority MEDIUM 51
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules.
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.06537 · Published 2026-06-17 · Fixed in 1.31.2, 1.30.3 +2 CWE-122
Priority MEDIUM 45
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module.
CVSS 4.0HIGH 8.8· Network · No auth · No interaction · EPSS 0.0074 · Published 2026-07-15 · Partial fix · 37.0.3.1, R36 P7 +2 CWE-908
Priority MEDIUM 40
When NGINX Ingress Controller is configured with Custom Resource Definitions (CRDs) or Ingress annotations, an injection vulnerability exists in the configuration generator of NGINX Ingress Controller.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00509 · Published 2026-07-15 · Fixed in 5.5.2, 2026-lts-r3 CWE-76
Priority MEDIUM 40
A vulnerability exists in NGINX Ingress Controller's nginx.org/rewrite-target annotation validation.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00434 · Published 2025-12-17 · Fixed in 5.3.1, 5.2.0 +4 CWE-22
Priority LOW 38
A vulnerability exists in the ngx_http_scgi_module and ngx_http_uwsgi_module modules that may result in excessive memory allocation or an over-read of data.
CVSS 4.0HIGH 8.3· Network · No auth · No interaction · EPSS 0.00932 · Published 2026-05-13 · Partial fix · R37, R36 P4 +3 CWE-789
Priority LOW 38
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module…
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00811 · Published 2022-10-19 · Partial fix · 1.23.2, 1.22.1 +4 CWE-787
Priority LOW 37
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssi_module module.
CVSS 4.0HIGH 8.3· Network · No auth · No interaction · EPSS 0.00486 · Published 2026-07-15 · Partial fix · 37.0.3.1, R36 P7 +2 CWE-416
Priority LOW 37
When NGINX Plus or NGINX Open Source are configured to use the HTTP/3 QUIC module, an attacker may be able to spoof their source IP address allowing for bypass of authorization or bypass of rate limiting.
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00373 · Published 2026-05-13 · Partial fix · R37, R36 P4 +3 CWE-290
Priority LOW 36
A vulnerability exists in NGINX OSS and NGINX Plus when configured to proxy to upstream Transport Layer Security (TLS) servers.
CVSS 4.0HIGH 8.2· Network · No auth · No interaction · EPSS 0.0038 · Published 2026-02-04 · Partial fix · 1.29.5, R36 P2 +2 CWE-349
Priority LOW 36
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module…
CVSS 3.1HIGH 7.1· Local · Low privileges · No interaction · EPSS 0.01179 · Published 2022-10-19 · Partial fix · 1.23.2, 1.22.1 +4 CWE-787
Priority LOW 34
When NGINX Open Source is configured to proxy HTTP/2 traffic by setting proxy_http_version to 2, and also uses proxy_set_body, an attacker may be able to inject frame headers and payload bytes to the upstream peer.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00346 · Published 2026-05-13 · Partial fix · 1.31.0, 1.30.1 CWE-172
Priority LOW 32
When NGINX Ingress Controller processes Ingress or TransportServer resources, an authenticated, remote attacker with permission to create or modify Ingress or TransportServer resources can cause the NGINX Ingress Control…
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00501 · Published 2026-07-15 · Fixed in 5.5.2, 2026-lts-r3 CWE-476
Priority LOW 32
NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_hls_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its crash or potential other impact using…
CVSS 3.1HIGH 7.0· Local · Low privileges · No interaction · EPSS 0.0023 · Published 2022-10-19 · Fixed in R27-p1, R26-p1 CWE-787
Priority LOW 30
In versions 2.x before 2.3.0 and all versions of 1.x, An attacker authorized to create or update ingress objects can obtain the secrets available to the NGINX Ingress Controller.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00714 · Published 2022-08-04 · Fixed in 2.3.0 CWE-20
Priority LOW 30
On version 2.x before 2.0.3 and 1.x before 1.12.3, the command line restriction that controls snippet use with NGINX Ingress Controller does not apply to Ingress objects.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00769 · Published 2022-04-21 · No fix listed CWE-732
Priority LOW 29
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00684 · Published 2026-06-17 · Partial fix · 1.31.2, 1.30.3 +2 CWE-125
Priority LOW 29
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00731 · Published 2026-05-13 · Partial fix · R37, R36 P4 +3 CWE-125
Priority LOW 29
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssl_module module when the ssl_verify_client directive is set to "on" or "optional," and the ssl_ocsp directive is set to "on" or the leaf parameters…
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.0069 · Published 2026-05-13 · Partial fix · R37, R36 P4 +3 CWE-416
Priority LOW 28
When NGINX Plus is configured to use the Message Queuing Telemetry Transport (MQTT) filter module (ngx_stream_mqtt_filter_module), unauthenticated attackers can send requests with conditions beyond the attacker's control…
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00448 · Published 2026-07-15 · Fixed in 37.0.3.1, R36 P7 CWE-125
Priority LOW 23
A session fixation issue was discovered in the NGINX OpenID Connect reference implementation, where a nonce was not checked at login time.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00369 · Published 2024-11-06 · Fixed in 2.17.4, 1.9.3 +1 CWE-384