Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

48 records

TI-2025-23435 CVE-2025-32352 · GHSA-2xch-5969-phfh

Type confusion in ZendTo

Priority MEDIUM 55

A type confusion vulnerability in lib/NSSAuthenticator.php in ZendTo before v5.04-7 allows remote attackers to bypass authentication for users with passwords stored as MD5 hashes that can be interpreted as numbers.

CVSS 3.1MEDIUM 4.8 Network No auth No interaction EPSS 0.00338 Published 2025-04-05 Fixed in 5.04-7 CWE-843
TI-2021-22301 CVE-2021-47667 · GHSA-r4mc-p68x-wx22

OS command injection in ZendTo

Priority HIGH 82

An OS command injection vulnerability in lib/NSSDropoff.php in ZendTo 5.24-3 through 6.x before 6.10-7 allows unauthenticated remote attackers to execute arbitrary commands via shell metacharacters in the tmp_name parame…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.36363 Published 2025-04-05 Fixed in 6.10-7 CWE-78
TI-2024-08478 CVE-2024-9129 · GHSA-56v6-7jgh-2f7r

Format String Injection in Zend Server

Priority MEDIUM 48

In versions of Zend Server 8.5 and prior to version 9.2 a format string injection was discovered.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00425 Published 2024-10-22 Fixed in 9.1 CWE-134
Priority HIGH 81

Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zen…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.75313 Published 2021-01-04 Fixed in 2.14.2 CWE-502
Priority MEDIUM 47

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0255 Published 2020-02-17 Fixed in 1.12.9, 2.0.99 +3 CWE-89
TI-2015-02787 CVE-2015-3154 · GHSA-5957-5crx-79jx

Injection in Zend Framework

Priority LOW 29

CRLF injection vulnerability in Zend\Mail (Zend_Mail) in Zend Framework before 1.12.12, 2.x before 2.3.8, and 2.4.x before 2.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splittin…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01009 Published 2020-01-27 Fixed in 1.12.12, 2.3.8 +1 CWE-74
TI-2012-03793 CVE-2012-4451 · GHSA-3rph-pvh6-rj33

Cross-site scripting in Zend Framework

Priority LOW 30

Multiple cross-site scripting (XSS) vulnerabilities in Zend Framework 2.0.x before 2.0.1 allow remote attackers to inject arbitrary web script or HTML via unspecified input to (1) Debug, (2) Feed\PubSubHubbub, (3) Log\Fo…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01367 Published 2020-01-03 Fixed in 2.0.1 CWE-79
Priority MEDIUM 49

SQL injection vulnerability in Zend Framework 1.10.x before 1.10.9 and 1.11.x before 1.11.6 when using non-ASCII-compatible encodings in conjunction PDO_MySql in PHP before 5.3.6.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03858 Published 2019-11-26 Fixed in 1.10.9, 1.11.6 +1 CWE-89
Priority MEDIUM 46

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.19 might allow remote attackers to conduct SQL injection attacks via vectors related to use of the character pattern [\w]* in a regu…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02047 Published 2017-02-16 Fixed in 1.12.19 CWE-89
Priority MEDIUM 49

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.20 might allow remote attackers to conduct SQL injection attacks by leveraging failure to remove comments from an SQL statement befo…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.04124 Published 2017-02-16 Fixed in 1.12.20 CWE-89
Priority HIGH 69

The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11, 2.5.x, 2.6.x, and 2.7.x before 2.7.2, and Zend Framework before 2.4.11 might allow remote attackers to pass extra parameters to the m…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.38438 Published 2016-12-30 Fixed in 2.4.11, 2.7.2 CWE-77
Load more