Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

89 records

Priority MEDIUM 41

A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01098 Published 2025-06-26 No fix listed CWE-78
Priority MEDIUM 43

Versions of Puppet Enterprise prior to 2021.7.6 and 2023.5 contain a flaw which results in broken session management for SAML implementations.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00496 Published 2023-11-07 Fixed in 2021.7.6, 2023.5 CWE-384
Priority LOW 33

For certificates that utilize the auto-renew feature in Puppet Server, a flaw exists which prevents the certificates from being revoked.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00476 Published 2023-10-03 No fix listed CWE-404
Priority LOW 30

A Regular Expression Denial of Service (ReDoS) issue was discovered in Puppet Server 7.9.2 certificate validation.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00437 Published 2023-05-04 Fixed in 2021.7.3, 2023.1.0 +2 CWE-1333
Priority LOW 24

A flaw was discovered in bolt-server and ace where running a task with sensitive parameters results in those sensitive parameters being logged when they should not be.

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.00916 Published 2021-09-07 No fix listed CWE-532
TI-2021-08594 CVE-2021-27021 · GHSA-j664-pgf6-rhhh

SQL injection in Puppet DB

Priority MEDIUM 41

A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01262 Published 2021-07-20 No fix listed CWE-1027
TI-2019-07982 CVE-2019-10694 · GHSA-8h2m-rx7g-r9gv

Hard-coded credentials in Puppet Enterprise

Priority MEDIUM 44

The express install, which is the suggested way to install Puppet Enterprise, gives the user a URL at the end of the install to set the admin password.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01089 Published 2019-12-11 No fix listed CWE-798
Priority LOW 29

Puppet Enterprise before 3.0.1 allows remote attackers to (1) conduct clickjacking attacks via unspecified vectors related to the console, and (2) conduct cross-site scripting (XSS) attacks via unspecified vectors relate…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00816 Published 2019-12-11 No fix listed CWE-79
TI-2015-01666 CVE-2015-1855 · GHSA-4x8v-74xf-h4g3

Improper input validation in Ruby

Priority LOW 32

verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers vi…

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.02815 Published 2019-11-29 Partial fix · 2.1.6 CWE-20
Priority MEDIUM 40

Puppet Enterprise 2016.4.x prior to 2016.4.12, Puppet Enterprise 2017.3.x prior to 2017.3.7, Puppet Enterprise 2018.1.x prior to 2018.1.1, Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, and Pupp…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.01117 Published 2018-06-11 No fix listed CWE-426
Priority LOW 25

A cross-site scripting vulnerability in Puppet Enterprise Console of Puppet Enterprise allows a user to inject scripts into the Puppet Enterprise Console when using the Puppet Enterprise Console.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00636 Published 2018-05-08 Fixed in 2017.3.6 CWE-79
Priority LOW 25

A cross-site scripting vulnerability in Puppet Enterprise Console of Puppet Enterprise allows a user to inject scripts into the Puppet Enterprise Console when using the Orchestrator.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00508 Published 2018-05-08 Fixed in 2017.3.6 CWE-79
Priority LOW 31

In previous versions of Puppet Agent it was possible for the agent to retrieve facts from an environment that it was not classified to retrieve from.

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01 Published 2018-02-09 Fixed in 2017.3.4, 5.3.4 CWE-269
Priority LOW 25

In previous versions of Puppet Agent it was possible to install a module with world writable permissions.

CVSS 3.0MEDIUM 5.5 Local Low privileges No interaction EPSS 0.00356 Published 2018-02-09 Partial fix · 4.10.10, 5.3.4 CWE-269
Load more