Priority MEDIUM 40
The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00784 · Published 2026-08-19 · Fixed in 4.19.3, 4.20.3 CWE-400
Priority MEDIUM 40
The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality.
CVSS 3.1HIGH 8.7· Network · High privileges · No interaction · EPSS 0.00472 · Published 2026-08-19 · Fixed in 4.19.3, 4.20.2 +2 CWE-295
Priority LOW 31
SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability.
CVSS 3.1HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00222 · Published 2026-07-17 · Fixed in 2.4.7, 2.5.2 CWE-345
Priority MEDIUM 44
SimpleSAMLphp-casserver is a CAS 1.0 and 2.0 compliant CAS server in the form of a SimpleSAMLphp module.
CVSS 3.1HIGH 8.6· Network · No auth · No interaction · EPSS 0.00422 · Published 2026-06-09 · Fixed in 7.0.3 CWE-22
Priority MEDIUM 60
SimpleSAMLphp-casserver is a CAS 1.0 and 2.0 compliant CAS server in the form of a SimpleSAMLphp module.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00269 · Published 2026-05-18 · Fixed in 6.3.1, 7.0.0 CWE-601
Priority HIGH 75
xml-security is a library that implements XML signatures and encryption.
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.00151 · Published 2026-03-13 · Fixed in 2.3.1, 1.13.9 CWE-354
Priority HIGH 76
The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality.
CVSS 3.1HIGH 8.6· Network · No auth · No interaction · EPSS 0.00415 · Published 2025-03-11 · Fixed in 4.17.0, 5.0.0-alpha.20 CWE-347
Priority MEDIUM 46
SimpleSAMLphp xml-common is a common classes for handling XML-structures.
CVSS 4.0HIGH 8.8· Network · No auth · No interaction · EPSS 0.00979 · Published 2024-12-02 · Fixed in 1.20.0 CWE-611
Priority MEDIUM 42
SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality.
CVSS 3.1HIGH 8.3· Network · No auth · No interaction · EPSS 0.00432 · Published 2024-12-02 · Fixed in 4.6.14, 5.0.0-alpha.18 CWE-611
Priority LOW 32
xml-security is a library that implements XML signatures and encryption.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00193 · Published 2023-11-30 · Partial fix · 1.6.12, 5.0.0-alpha.13 CWE-345
Priority LOW 25
** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00589 · Published 2023-01-17 · Fixed in 0.9.0 CWE-79
Priority LOW 28
A vulnerability was found in Information Cards Module on simpleSAMLphp and classified as problematic.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00536 · Published 2023-01-09 · Fixed in 1.0 CWE-79
Priority LOW 28
** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic has been found in SimpleSAMLphp simplesamlphp-module-openid.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00695 · Published 2023-01-01 · Fixed in 1.0 CWE-79
Priority LOW 17
SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability.
CVSS 3.1LOW 3.1· Network · Low privileges · No interaction · EPSS 0.00922 · Published 2020-04-21 · Fixed in 1.18.6 CWE-200
Priority LOW 25
Cross-site scripting in SimpleSAMLphp before version 1.18.4.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00544 · Published 2020-01-24 · Fixed in 1.18.4 CWE-79
Priority LOW 25
Log injection in SimpleSAMLphp before version 1.18.4.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · No interaction · EPSS 0.00659 · Published 2020-01-24 · Fixed in 1.18.4 CWE-532
Priority MEDIUM 43
Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate o…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02988 · Published 2019-11-07 · Fixed in 3.0.4, 2.1.1 CWE-347
Priority LOW 34
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00744 · Published 2019-11-06 · Fixed in 1.8.1 CWE-755
Priority LOW 38
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forc…
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.01189 · Published 2018-03-05 · Fixed in 1.10.6, 2.3.8 +1 CWE-347
Priority LOW 36
The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Iden…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.0145 · Published 2018-03-05 · Fixed in 1.10.5, 2.3.7 +1 CWE-347
Priority LOW 37
A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16.
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.01093 · Published 2018-02-02 · Fixed in 1.14.17 CWE-347
Priority LOW 30
The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01194 · Published 2018-02-02 · Fixed in 1.14.16 CWE-79
Priority MEDIUM 48
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03053 · Published 2018-02-02 · Fixed in 1.15.2
Priority LOW 29
SimpleSAMLphp before 1.15.2 allows remote attackers to bypass an open redirect protection mechanism via crafted authority data in a URL.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00851 · Published 2018-02-02 · Fixed in 1.15.2 CWE-601
Priority LOW 36
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.01696 · Published 2018-02-02 · Fixed in 1.10.4, 2.3.5 +1 CWE-74
Load more